Re: [PATCH 2/3] usb: dwc3: add may_lose_power flag
From: Thinh Nguyen <Thinh.Nguyen@synopsys.com>
Date: 2026-02-03 00:24:49
Also in:
imx, linux-devicetree, linux-usb, lkml
On Mon, Feb 02, 2026, Xu Yang wrote:
quoted hunk ↗ jump to hunk
The current design assumes that the controller remains powered when wakeup is enabled. However, some SoCs provide wakeup capability even when the controller itself is powered down, using separate dedicated wakeup logic. This allows additional power savings, but requires the controller to be fully re‑initialized after system resume. To support these SoCs, introduce a flag to track the controller’s power state and use it throughout the suspend/resume flow. Signed-off-by: Xu Yang <xu.yang_2@nxp.com> --- drivers/usb/dwc3/core.c | 9 +++++++-- drivers/usb/dwc3/core.h | 2 ++ drivers/usb/dwc3/glue.h | 3 +++ 3 files changed, 12 insertions(+), 2 deletions(-)diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c index c07ffe82c85049364c38c7ba152aab0ff764d95e..9d4326da5ec7669fa714707fb24556723cab51b8 100644 --- a/drivers/usb/dwc3/core.c +++ b/drivers/usb/dwc3/core.c@@ -2314,6 +2314,9 @@ int dwc3_core_probe(const struct dwc3_probe_data *data) goto err_exit_debugfs; } + if (data->core_may_lose_power)
Can this be passed down as part of the dwc3_properties within the probe_data? I'm trying to consolidate all the dwc3 properties to one place.
quoted hunk ↗ jump to hunk
+ dwc->may_lose_power = true; + pm_runtime_put(dev); dma_set_max_seg_size(dev, UINT_MAX);@@ -2462,7 +2465,8 @@ static int dwc3_suspend_common(struct dwc3 *dwc, pm_message_t msg) dwc3_core_exit(dwc); break; case DWC3_GCTL_PRTCAP_HOST: - if (!PMSG_IS_AUTO(msg) && !device_may_wakeup(dwc->dev)) { + if (!PMSG_IS_AUTO(msg) && + (!device_may_wakeup(dwc->dev) || dwc->may_lose_power)) { dwc3_core_exit(dwc); break; }@@ -2525,7 +2529,8 @@ static int dwc3_resume_common(struct dwc3 *dwc, pm_message_t msg) dwc3_gadget_resume(dwc); break; case DWC3_GCTL_PRTCAP_HOST: - if (!PMSG_IS_AUTO(msg) && !device_may_wakeup(dwc->dev)) { + if (!PMSG_IS_AUTO(msg) && + (!device_may_wakeup(dwc->dev) || dwc->may_lose_power)) { ret = dwc3_core_init_for_resume(dwc); if (ret) return ret;diff --git a/drivers/usb/dwc3/core.h b/drivers/usb/dwc3/core.h index 08cc6f2b5c23631a752c77fd7394e5876c929f0a..5b1358f36490a001bc9e68139224f7be70a57995 100644 --- a/drivers/usb/dwc3/core.h +++ b/drivers/usb/dwc3/core.h@@ -1117,6 +1117,7 @@ struct dwc3_glue_ops { * @usb3_lpm_capable: set if hadrware supports Link Power Management * @usb2_lpm_disable: set to disable usb2 lpm for host * @usb2_gadget_lpm_disable: set to disable usb2 lpm for gadget + * @may_lose_power: set to indicate the core may lose power during pm suspend * @disable_scramble_quirk: set if we enable the disable scramble quirk * @u2exit_lfps_quirk: set if we enable u2exit lfps quirk * @u2ss_inp3_quirk: set if we enable P3 OK for U2/SS Inactive quirk@@ -1369,6 +1370,7 @@ struct dwc3 { unsigned usb3_lpm_capable:1; unsigned usb2_lpm_disable:1; unsigned usb2_gadget_lpm_disable:1; + unsigned may_lose_power:1;
This name sounds like a quirk of a broken SoC. Perhaps rename this to something such as power_lost_on_suspend or needs_full_reinit? BR, Thinh
quoted hunk ↗ jump to hunk
unsigned disable_scramble_quirk:1; unsigned u2exit_lfps_quirk:1;diff --git a/drivers/usb/dwc3/glue.h b/drivers/usb/dwc3/glue.h index df86e14cb706ca509206677f644da2a7225b1b26..b428a9f4a32625e7331f8492a408f7c20c915825 100644 --- a/drivers/usb/dwc3/glue.h +++ b/drivers/usb/dwc3/glue.h@@ -29,6 +29,8 @@ struct dwc3_properties { * be ignored by the DWC3 core, as they are managed by the glue * @skip_core_init_mode: Skip the finial initialization of the target mode, as * it must be managed by the glue + * @core_may_lose_power: indicate the controller may not remain power during + * system suspend/resume * @properties: dwc3 software manage properties */ struct dwc3_probe_data {@@ -36,6 +38,7 @@ struct dwc3_probe_data { struct resource *res; bool ignore_clocks_and_resets; bool skip_core_init_mode; + bool core_may_lose_power; struct dwc3_properties properties; };-- 2.34.1