Re: [PATCH v3 2/3] arm64: Optimize __READ_ONCE() with CONFIG_LTO=y
From: Will Deacon <will@kernel.org>
Date: 2026-02-02 16:05:44
Also in:
lkml, llvm
From: Will Deacon <will@kernel.org>
Date: 2026-02-02 16:05:44
Also in:
lkml, llvm
On Mon, Feb 02, 2026 at 05:01:39PM +0100, Peter Zijlstra wrote:
On Mon, Feb 02, 2026 at 03:36:40PM +0000, Will Deacon wrote:quoted
Since we're not providing acquire semantics for the non-atomic case, what we really want is the generic definition of __READ_ONCE() from include/asm-generic/rwonce.h here. The header inclusion mess prevents that, but why can't we just inline that definition here for the 'default' case? If TYPEOF_UNQUAL() leads to better codegen, shouldn't we use that to implement __unqual_scalar_typeof() when it is available?We are?
Great! Then I don't grok why we need to choose between __unqual_scalar_typeof() and __typeof_unqual__() in the arch code. We should just use the former and it will DTRT. Will