Thread (41 messages) 41 messages, 4 authors, 2026-02-04

Re: [PATCH v8 05/18] drm/bridge: Move legacy bridge driver out of imx directory for multi-platform use

From: Damon Ding <hidden>
Date: 2026-02-02 02:54:51
Also in: dri-devel, imx, linux-rockchip, linux-samsung-soc, lkml

Hi Luca,

On 1/31/2026 8:33 PM, Luca Ceresoli wrote:
Hello Damon, Dmitry,

On Wed Dec 17, 2025 at 10:33 AM CET, Damon Ding wrote:
quoted
As suggested by Dmitry, the DRM legacy bridge driver can be pulled
out of imx/ subdir for multi-platform use. The driver is also renamed
to make it more generic and suitable for platforms other than i.MX.

Signed-off-by: Damon Ding <redacted>
Suggested-by: Dmitry Baryshkov <redacted>
Tested-by: Marek Szyprowski <m.szyprowski@samsung.com>

---

Changes in v7:
- Rename legacy-bridge to of-display-mode-bridge.
- Remove unnecessary API drm_bridge_is_legacy().
...
quoted
--- a/drivers/gpu/drm/bridge/Kconfig
+++ b/drivers/gpu/drm/bridge/Kconfig
@@ -244,6 +244,16 @@ config DRM_NXP_PTN3460
  	help
  	  NXP PTN3460 eDP-LVDS bridge chip driver.

+config DRM_OF_DISPLAY_MODE_BRIDGE
+	tristate
+	depends on DRM_BRIDGE && OF
+	help
+	  This is a DRM bridge implementation that uses of_get_drm_display_mode
+	  to acquire display mode.
+
+	  Newer designs should not use this bridge and should use proper panel
+	  driver instead.
"Newer designs should not use this bridge", but in patch 8 you are
introducing a new use ot devm_drm_of_display_mode_bridge(). Shouldn't you
instead "use proper panel driver instead" in patch 8?

Can you point to the conversation where the converstaion where Dmitry
suggested this change? Maybe it already contains the answer to my
qustion. Also adding a link to that conversation in the commit message
woule be useful.
First of all, thanks for your reviews on this patch series.

link: 
https://lore.kernel.org/all/xwenycscalzdlpuxytorbiyvej3k7pv3lhxwtadilxq65ipwsv@x5rxm53w5e22/ (local)

I think it may be a misleading issue caused by directly copying the 
previous Kconfig description. Now that the new 
devm_drm_of_display_mode_bridge() helper has been added, drivers using 
the panel-bridge framework can rely on it to maintain compatibility with 
legacy display mode parsing.

It would be better to update the comment as follows:

This is a DRM bridge implementation that uses of_get_drm_display_mode to 
acquire display mode.

It exists for compatibility with legacy display mode parsing, in order 
to conform to the panel-bridge framework.

Best regards,
Damon

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help