On Thu, Sep 11, 2025 at 03:49:44PM +0200, Jens Wiklander wrote:
+static const char *heap_id_2_name(enum tee_dma_heap_id id)
+{
+ switch (id) {
+ case TEE_DMA_HEAP_SECURE_VIDEO_PLAY:
+ return "protected,secure-video";
+ case TEE_DMA_HEAP_TRUSTED_UI:
+ return "protected,trusted-ui";
+ case TEE_DMA_HEAP_SECURE_VIDEO_RECORD:
+ return "protected,secure-video-record";
+ default:
+ return NULL;
+ }
+}
We've recently agreed on a naming guideline (even though it's not merged yet)
https://lore.kernel.org/r/20250728-dma-buf-heap-names-doc-v4-1-f73f71cf0dfd@kernel.org (local)
Secure and trusted should be defined I guess, because secure and
protected at least seem redundant to me.
Maxime