On Thu, Sep 11 2025 at 15:13, Marc Zyngier wrote:
On Tue, 09 Sep 2025 10:18:01 +0100,
Thomas Gleixner [off-list ref] wrote:
quoted
On Mon, Sep 08 2025 at 17:31, Marc Zyngier wrote:
[...]
quoted
quoted
@@ -69,6 +90,8 @@ void of_phandle_args_to_fwspec(struct device_node *np, const u32 *args,
* @translate: Given @fwspec, decode the hardware irq number (@out_hwirq) and
* linux irq type value (@out_type). This is a generalised @xlate
* (over struct irq_fwspec) and is preferred if provided.
+ * @get_info: Given @info, report additional firmware-provided information.
+ * Optional.
get_info() is pretty generic. Can we have some more descriptive name for
that? Also please keep the tabular formatting of the doc intact.
Would get_fwspec_info() be descriptive enough?
I think so