Thread (29 messages) 29 messages, 5 authors, 2025-02-21

RE: [PATCH 1/8] media: platform: chips-media: wave5: Rename Kconfig parameter

From: Nas Chung <nas.chung@chipsnmedia.com>
Date: 2025-02-11 04:23:40
Also in: linux-devicetree, linux-media, lkml

Hi, Krzysztof.
-----Original Message-----
From: Krzysztof Kozlowski <krzk@kernel.org>
Sent: Tuesday, February 11, 2025 2:24 AM
To: Nas Chung <nas.chung@chipsnmedia.com>; mchehab@kernel.org;
hverkuil@xs4all.nl; sebastian.fricke@collabora.com; robh@kernel.org;
krzk+dt@kernel.org; conor+dt@kernel.org
Cc: linux-media@vger.kernel.org; devicetree@vger.kernel.org; linux-
kernel@vger.kernel.org; linux-imx@nxp.com; linux-arm-
kernel@lists.infradead.org; jackson.lee [off-list ref];
lafley.kim [off-list ref]
Subject: Re: [PATCH 1/8] media: platform: chips-media: wave5: Rename
Kconfig parameter

On 10/02/2025 10:07, Nas Chung wrote:
quoted
The existing Kconfig parameter VIDEO_WAVE_VPU is ambiguous,
as it does not clearly indicate that it is specific to the Wave5 IP.

Rename VIDEO_WAVE_VPU to VIDEO_WAVE5_VPU to make it explicit
that the parameter is specific to the Wave5 IP.

No functional changes, only the parameter name is updated.

That's unnecessary churn. Old name was fine. Kconfig does not match
hardware 1-to-1 but represents only the driver name (or not even that...).

If you solve any particular problem, then explain it. Otherwise this is
just unnecessarily affecting users and backports.
I understand your point.
To avoid unnecessary changes, I'll drop this patch.

Thank you for your feedback.

Thanks.
Nas.
quoted
Signed-off-by: Nas Chung <nas.chung@chipsnmedia.com>
---
 arch/arm64/configs/defconfig                      | 2 +-
That's a SoC patch, don't mix up subsystems.


Best regards,
Krzysztof
  
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help