Re: [PATCH 1/8] media: platform: chips-media: wave5: Rename Kconfig parameter
From: Krzysztof Kozlowski <krzk@kernel.org>
Date: 2025-02-10 17:24:20
Also in:
linux-devicetree, linux-media, lkml
From: Krzysztof Kozlowski <krzk@kernel.org>
Date: 2025-02-10 17:24:20
Also in:
linux-devicetree, linux-media, lkml
On 10/02/2025 10:07, Nas Chung wrote:
The existing Kconfig parameter VIDEO_WAVE_VPU is ambiguous, as it does not clearly indicate that it is specific to the Wave5 IP. Rename VIDEO_WAVE_VPU to VIDEO_WAVE5_VPU to make it explicit that the parameter is specific to the Wave5 IP. No functional changes, only the parameter name is updated.
That's unnecessary churn. Old name was fine. Kconfig does not match hardware 1-to-1 but represents only the driver name (or not even that...). If you solve any particular problem, then explain it. Otherwise this is just unnecessarily affecting users and backports.
Signed-off-by: Nas Chung <nas.chung@chipsnmedia.com> --- arch/arm64/configs/defconfig | 2 +-
That's a SoC patch, don't mix up subsystems. Best regards, Krzysztof