Re: [PATCH v5 6/9] iommu/arm-smmu-v3: Move CD table to arm_smmu_master
From: Will Deacon <will@kernel.org>
Date: 2023-08-10 14:34:57
Also in:
linux-iommu, lkml
From: Will Deacon <will@kernel.org>
Date: 2023-08-10 14:34:57
Also in:
linux-iommu, lkml
On Thu, Aug 10, 2023 at 05:45:03PM +0800, Michael Shavit wrote:
On Wed, Aug 9, 2023 at 9:50 PM Will Deacon [off-list ref] wrote:quoted
On Wed, Aug 09, 2023 at 01:12:02AM +0800, Michael Shavit wrote:quoted
@@ -2203,7 +2186,7 @@ static int arm_smmu_domain_finalise(struct iommu_domain *domain, ias = min_t(unsigned long, ias, VA_BITS); oas = smmu->ias; fmt = ARM_64_LPAE_S1; - finalise_stage_fn = arm_smmu_domain_finalise_s1; + finalise_stage_fn = arm_smmu_domain_finalise_cd;Why is this a better name? Now we have inconsistency with arm_smmu_domain_finalise_s2().There was a time where s1cfg represented the entire STE and carried the entire cd table. We've gotten rid of s1cfg, and now only store arm_smmu_ctx_desc in the arm_smmu_domain for stage 1 domains. arm_smmu_domain_finalise_cd is IMO more clear, especially given the historical baggage around `s1`.
Ok, but it's the inconsistency I object to. I don't think it's clear at all to have arm_smmu_domain_finalise_cd() and arm_smmu_domain_finalise_s2(). The easiest thing is to leave it as-is. Will _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel