On Mon, 27 Feb 2023 at 20:51, Rob Herring [off-list ref] wrote:
quoted
+properties:
+ compatible:
+ const: apple,z2-touchscreen
Is 'z2' anything other than a touchscreen? If not, '-touchscreen' is
redundant. If so, then what else is there? You should be describing
physical devices, not just a protocol for touchscreen.
This is a class of touchscreen controllers that talk the z2 protocol
over spi.
quoted
+ touchscreen-size-y = <640>;
+ apple,z2-device-name = "MacBookPro17,1 Touch Bar";
Why do we need this string? If you want a human consumed label for
some identification, we have a property for that purpose. It's called
'label'. But when there is only 1 instance, I don't really see the
point.
I want a libinput-consumed label to distinguish between devices
using this protocol. It is used both for 'normal' touchscreens, and,
as is in this example a 'touchbar', which absolutely should not be
treated as a normal touchscreen, and needs special handling in
userspace.
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel