On 2021/12/16 19:17, Borislav Petkov wrote:
On Fri, Dec 10, 2021 at 02:55:28PM +0800, Zhen Lei wrote:
quoted
+ * reserve_crashkernel() - reserves memory for crash kernel
+ *
+ * This function reserves memory area given in "crashkernel=" kernel command
+ * line parameter. The memory reserved is used by dump capture kernel when
+ * primary kernel is crashing.
+ */
+void __init reserve_crashkernel(void)
As I've already alluded to in another mail, ontop of this there should
be a patch or multiple patches which clean this up more and perhaps even
split it into separate functions doing stuff in this order:
1. Parse all crashkernel= cmdline options
2. Do all crash_base, crash_size etc checks
3. Do the memory reservations
And all that supplied with comments explaining why stuff is being done.
I agree with you. This makes the code look clear. I will do it, try to
post v18 next Monday.
This set of functions is a mess and there's no better time for cleaning
it up and documenting it properly than when you move it to generic code.
Thx.
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel