Re: [PATCH] kselftest/arm64: pac: Fix skipping of tests on systems without PAC
From: Mark Brown <broonie@kernel.org>
Date: 2021-08-20 10:57:41
Also in:
linux-kselftest
From: Mark Brown <broonie@kernel.org>
Date: 2021-08-20 10:57:41
Also in:
linux-kselftest
On Fri, Aug 20, 2021 at 12:39:39PM +0530, Amit Kachhap wrote:
On 8/19/21 10:27 PM, Mark Brown wrote:
quoted
- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled"); \ + if (!(hwcaps & HWCAP_PACA)) \ + SKIP(return, "PAUTH not enabled"); \ } while (0) #define ASSERT_GENERIC_PAUTH_ENABLED() \
May be ASSERT_GENERIC_PAUTH_ENABLED can be replaced with something like VERIFY_GENERIC_PAUTH_ENABLED
I thought briefly about bikeshedding the name but didn't come up with anything that was sufficiently better/clearer.
or can be modified like below and instead of failing it skips with a message
- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled"); \
+ ASSERT_NE(0, hwcaps & HWCAP_PACA) SKIP(return, "PAUTH not enabled");That's what the patch does?