From: Mark Brown <broonie@kernel.org> Date: 2021-08-19 16:59:41
The PAC tests check to see if the system supports the relevant PAC features
but instead of skipping the tests if they can't be executed they fail the
tests which makes things look like they're not working when they are.
Signed-off-by: Mark Brown <broonie@kernel.org>
---
tools/testing/selftests/arm64/pauth/pac.c | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
@@ -25,13 +25,15 @@do{\unsignedlonghwcaps=getauxval(AT_HWCAP);\/* data key instructions are not in NOP space. This prevents a SIGILL */\-ASSERT_NE(0,hwcaps&HWCAP_PACA)TH_LOG("PAUTH not enabled");\+if(!(hwcaps&HWCAP_PACA))\+SKIP(return,"PAUTH not enabled");\}while(0)#define ASSERT_GENERIC_PAUTH_ENABLED() \do{\unsignedlonghwcaps=getauxval(AT_HWCAP);\/* generic key instructions are not in NOP space. This prevents a SIGILL */\-ASSERT_NE(0,hwcaps&HWCAP_PACG)TH_LOG("Generic PAUTH not enabled");\+if(!(hwcaps&HWCAP_PACG))\+SKIP(return,"Generic PAUTH not enabled");\}while(0)voidsign_specific(structsignatures*sign,size_tval)
@@ -256,7 +258,7 @@ TEST(single_thread_different_keys)unsignedlonghwcaps=getauxval(AT_HWCAP);/* generic and data key instructions are not in NOP space. This prevents a SIGILL */-ASSERT_NE(0,hwcaps&HWCAP_PACA)TH_LOG("PAUTH not enabled");+ASSERT_PAUTH_ENABLED();if(!(hwcaps&HWCAP_PACG)){TH_LOG("WARNING: Generic PAUTH not enabled. Skipping generic key checks");nkeys=NKEYS-1;
@@ -299,7 +301,7 @@ TEST(exec_changed_keys)unsignedlonghwcaps=getauxval(AT_HWCAP);/* generic and data key instructions are not in NOP space. This prevents a SIGILL */-ASSERT_NE(0,hwcaps&HWCAP_PACA)TH_LOG("PAUTH not enabled");+ASSERT_PAUTH_ENABLED();if(!(hwcaps&HWCAP_PACG)){TH_LOG("WARNING: Generic PAUTH not enabled. Skipping generic key checks");nkeys=NKEYS-1;
--
2.20.1
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Amit Kachhap <hidden> Date: 2021-08-20 07:11:41
On 8/19/21 10:27 PM, Mark Brown wrote:
quoted hunk
The PAC tests check to see if the system supports the relevant PAC features
but instead of skipping the tests if they can't be executed they fail the
tests which makes things look like they're not working when they are.
Signed-off-by: Mark Brown <broonie@kernel.org>
---
tools/testing/selftests/arm64/pauth/pac.c | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
@@ -25,13 +25,15 @@do{\unsignedlonghwcaps=getauxval(AT_HWCAP);\/* data key instructions are not in NOP space. This prevents a SIGILL */\-ASSERT_NE(0,hwcaps&HWCAP_PACA)TH_LOG("PAUTH not enabled");\+if(!(hwcaps&HWCAP_PACA))\+SKIP(return,"PAUTH not enabled");\}while(0)#define ASSERT_GENERIC_PAUTH_ENABLED() \
May be ASSERT_GENERIC_PAUTH_ENABLED can be replaced with
something like VERIFY_GENERIC_PAUTH_ENABLED
or can be modified like below and instead of failing it skips with a
message
- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled"); \
+ ASSERT_NE(0, hwcaps & HWCAP_PACA) SKIP(return, "PAUTH not
enabled"); \
quoted hunk
do { \
unsigned long hwcaps = getauxval(AT_HWCAP); \
/* generic key instructions are not in NOP space. This prevents a SIGILL */ \
- ASSERT_NE(0, hwcaps & HWCAP_PACG) TH_LOG("Generic PAUTH not enabled"); \
+ if (!(hwcaps & HWCAP_PACG)) \
+ SKIP(return, "Generic PAUTH not enabled"); \
} while (0)
void sign_specific(struct signatures *sign, size_t val)
@@ -256,7 +258,7 @@ TEST(single_thread_different_keys) unsigned long hwcaps = getauxval(AT_HWCAP); /* generic and data key instructions are not in NOP space. This prevents a SIGILL */- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled");+ ASSERT_PAUTH_ENABLED(); if (!(hwcaps & HWCAP_PACG)) { TH_LOG("WARNING: Generic PAUTH not enabled. Skipping generic key checks"); nkeys = NKEYS - 1;
@@ -299,7 +301,7 @@ TEST(exec_changed_keys) unsigned long hwcaps = getauxval(AT_HWCAP); /* generic and data key instructions are not in NOP space. This prevents a SIGILL */- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled");+ ASSERT_PAUTH_ENABLED(); if (!(hwcaps & HWCAP_PACG)) { TH_LOG("WARNING: Generic PAUTH not enabled. Skipping generic key checks"); nkeys = NKEYS - 1;
From: Amit Kachhap <hidden> Date: 2021-08-20 11:45:13
On 8/20/21 4:25 PM, Mark Brown wrote:
On Fri, Aug 20, 2021 at 12:39:39PM +0530, Amit Kachhap wrote:
quoted
On 8/19/21 10:27 PM, Mark Brown wrote:
quoted
quoted
- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled"); \
+ if (!(hwcaps & HWCAP_PACA)) \
+ SKIP(return, "PAUTH not enabled"); \
} while (0)
#define ASSERT_GENERIC_PAUTH_ENABLED() \
quoted
May be ASSERT_GENERIC_PAUTH_ENABLED can be replaced with
something like VERIFY_GENERIC_PAUTH_ENABLED
I thought briefly about bikeshedding the name but didn't come up with
anything that was sufficiently better/clearer.
quoted
or can be modified like below and instead of failing it skips with a
message
quoted
- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled"); \
+ ASSERT_NE(0, hwcaps & HWCAP_PACA) SKIP(return, "PAUTH not enabled");
That's what the patch does?
Agree, I saw few other testcases where ASSERT is used along with SKIP.
(tools/testing/selftests/core/close_range_test.c) so this way
ASSERT_GENERIC_* macro will be clear. There will be just an extra
log like "hwcaps & HWCAP_PACA = 0" in this case.
Probably your way is consistent as other tests in arm64 also just
skips due to HWCAP mismatch.
From: Mark Brown <broonie@kernel.org> Date: 2021-08-20 12:06:19
On Fri, Aug 20, 2021 at 05:05:05PM +0530, Amit Kachhap wrote:
On 8/20/21 4:25 PM, Mark Brown wrote:
quoted
On Fri, Aug 20, 2021 at 12:39:39PM +0530, Amit Kachhap wrote:
quoted
quoted
- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled"); \
+ ASSERT_NE(0, hwcaps & HWCAP_PACA) SKIP(return, "PAUTH not enabled");
quoted
That's what the patch does?
Agree, I saw few other testcases where ASSERT is used along with SKIP.
(tools/testing/selftests/core/close_range_test.c) so this way
ASSERT_GENERIC_* macro will be clear. There will be just an extra
log like "hwcaps & HWCAP_PACA = 0" in this case.
I'm not 100% sure I follow what you're saying here? I don't see a log
message saying "hwcaps & HWCAP_PACA = 0" on non-PAC systems, or is that
what you're saying you want to see?
Probably your way is consistent as other tests in arm64 also just
skips due to HWCAP mismatch.
Right, we can't usefully run tests for features not present in the
system - this sort of thing is the intent of the kselftest skip feature.
On Thu, 19 Aug 2021 17:57:23 +0100, Mark Brown wrote:
The PAC tests check to see if the system supports the relevant PAC features
but instead of skipping the tests if they can't be executed they fail the
tests which makes things look like they're not working when they are.