Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/wm831x-otp.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/ucb1x00-assabet.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/timberdale.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/sm501.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
Use DEVICE_ATTR_ADMIN_RO macro helper instead of plain DEVICE_ATTR, which
makes the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/pcf50633-core.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/janz-cmodio.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Use DEVICE_ATTR_ADMIN_RW macro helper instead of plain DEVICE_ATTR, which
makes the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/intel_soc_pmic_bxtwc.c | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/kempld-core.c | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)
Use DEVICE_ATTR_RO/RW macro helper instead of plain DEVICE_ATTR, which
makes the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/ab8500-core.c | 33 ++++++++++++++++-----------------
1 file changed, 16 insertions(+), 17 deletions(-)
From: Charles Keepax <ckeepax@opensource.cirrus.com> Date: 2021-06-02 12:39:43
On Wed, Jun 02, 2021 at 07:43:31PM +0800, Zhen Lei wrote:
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
Acked-by: Charles Keepax <ckeepax@opensource.cirrus.com>
Thanks,
Charles
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 11:51:00
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/wm831x-otp.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 11:51:25
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/ucb1x00-assabet.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 11:51:57
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/timberdale.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 12:03:11
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/sm501.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 12:03:40
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_ADMIN_RO macro helper instead of plain DEVICE_ATTR, which
makes the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/pcf50633-core.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 12:14:13
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/kempld-core.c | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 12:14:42
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/janz-cmodio.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 12:15:06
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_ADMIN_RW macro helper instead of plain DEVICE_ATTR, which
makes the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/intel_soc_pmic_bxtwc.c | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Lee Jones <hidden> Date: 2021-06-15 12:15:28
On Wed, 02 Jun 2021, Zhen Lei wrote:
Use DEVICE_ATTR_RO/RW macro helper instead of plain DEVICE_ATTR, which
makes the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <redacted>
---
drivers/mfd/ab8500-core.c | 33 ++++++++++++++++-----------------
1 file changed, 16 insertions(+), 17 deletions(-)
Applied, thanks.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel