Thread (47 messages) 47 messages, 8 authors, 2021-01-26

Re: [PATCH v3 14/21] dt-bindings: usb: Add H616 compatible string

From: Maxime Ripard <hidden>
Date: 2021-01-18 15:51:28
Also in: linux-devicetree, lkml

On Mon, Jan 18, 2021 at 02:08:41AM +0000, Andre Przywara wrote:
quoted hunk ↗ jump to hunk
The H616 has four PHYs as the H3, along with their respective clock
gates and resets, so the property description is identical.

However the PHYs itself need some special bits, so we need a new
compatible string for it.

Signed-off-by: Andre Przywara <andre.przywara@arm.com>
---
 .../devicetree/bindings/phy/allwinner,sun8i-h3-usb-phy.yaml   | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/Documentation/devicetree/bindings/phy/allwinner,sun8i-h3-usb-phy.yaml b/Documentation/devicetree/bindings/phy/allwinner,sun8i-h3-usb-phy.yaml
index 60c344585276..f6f2dcb6dc1e 100644
--- a/Documentation/devicetree/bindings/phy/allwinner,sun8i-h3-usb-phy.yaml
+++ b/Documentation/devicetree/bindings/phy/allwinner,sun8i-h3-usb-phy.yaml
@@ -15,7 +15,9 @@ properties:
     const: 1
 
   compatible:
-    const: allwinner,sun8i-h3-usb-phy
+    oneOf:
+      - const: allwinner,sun8i-h3-usb-phy
+      - const: allwinner,sun50i-h616-usb-phy
While equivalent, enums produce errors that are easier to read. It would
be better to switch to one here

Maxime
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help