Re: [RFC PATCH 16/27] KVM: arm64: Prepare Hyp memory protection
From: Marc Zyngier <maz@kernel.org>
Date: 2020-12-07 13:55:43
Also in:
kvmarm, linux-devicetree, lkml
On 2020-12-07 11:58, Quentin Perret wrote:
On Monday 07 Dec 2020 at 11:16:05 (+0000), Fuad Tabba wrote:quoted
On Fri, Dec 4, 2020 at 6:01 PM Quentin Perret [off-list ref] wrote:quoted
On Thursday 03 Dec 2020 at 12:57:33 (+0000), Fuad Tabba wrote: <snip>quoted
quoted
+int hyp_create_idmap(void); +int hyp_map_vectors(void); +int hyp_back_vmemmap(phys_addr_t phys, unsigned long size, phys_addr_t back); +int hyp_cpu_set_vector(enum arm64_hyp_spectre_vector slot); +int hyp_create_mappings(void *from, void *to, enum kvm_pgtable_prot prot); +int __hyp_create_mappings(unsigned long start, unsigned long size, + unsigned long phys, unsigned long prot); +unsigned long __hyp_create_private_mapping(phys_addr_t phys, size_t size, + unsigned long prot); +nit: I also thought that the hyp_create_mappings function names are a bit confusing, since there's the create_hyp_mappings functions which use the aforementioned *hyp_pgtable.Sure, happy to re-name those (and hyp_pgtable above). Any suggestions?Perhaps something to indicate that these are temporary, tmp_ or bootstrap_ maybe?Hmm, the thing is these are temporary only in protected mode, they're permanent otherwise :/ Perhaps I could prefix the protected pgtable (and associated functions) with 'pkvm_' or so? Marc, any preferences?
None. Whichever name you pick, someone will ask you to change it.
Just call it Bob.
What I really *don't* want is see a blanket rename of existing symbols
or concepts.
Thanks,
M.
--
Jazz is not dead. It just smells funny...
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel