On 08/02/20 at 07:36pm, Mike Rapoport wrote:
From: Mike Rapoport <redacted>
Iteration over memblock.reserved with for_each_reserved_mem_region() used
__next_reserved_mem_region() that implemented a subset of
__next_mem_region().
Use __for_each_mem_range() and, essentially, __next_mem_region() with
appropriate parameters to reduce code duplication.
While on it, rename for_each_reserved_mem_region() to
for_each_reserved_mem_range() for consistency.
Signed-off-by: Mike Rapoport <redacted>
---
.clang-format | 2 +-
arch/arm64/kernel/setup.c | 2 +-
drivers/irqchip/irq-gic-v3-its.c | 2 +-
include/linux/memblock.h | 12 +++------
mm/memblock.c | 46 +++++++-------------------------
5 files changed, 17 insertions(+), 47 deletions(-)
Reviewed-by: Baoquan He <redacted>
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel