Re: [PATCH v3 2/9] KVM: x86: Move init-only kvm_x86_ops to separate struct
From: Paolo Bonzini <pbonzini@redhat.com>
Date: 2020-03-23 19:47:14
Also in:
kvm, kvmarm, linux-mips, lkml
From: Paolo Bonzini <pbonzini@redhat.com>
Date: 2020-03-23 19:47:14
Also in:
kvm, kvmarm, linux-mips, lkml
On 23/03/20 17:24, Vitaly Kuznetsov wrote:
Sounds cool! (not sure that with only two implementations people won't call it 'over-engineered' but cool).
Yes, something like #define KVM_X86_OP(name) .name = vmx_##name (svm_##name for svm.c) and then KVM_X86_OP(check_nested_events) etc.
My personal wish would just be that function names in function implementations are not auto-generated so e.g. a simple 'git grep vmx_hardware_setup' works
Yes, absolutely; the function names would still be written by hand. Paolo
but the way how we fill vmx_x86_ops in can be macroed I guess.
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel