Thread (3 messages) 3 messages, 3 authors, 2020-02-20

Re: [PATCH net-next v4] net: page_pool: API cleanup and comments

From: David Miller <davem@davemloft.net>
Date: 2020-02-20 00:19:33
Also in: bpf, lkml, netdev

From: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Date: Tue, 18 Feb 2020 16:10:31 +0200
Functions starting with __ usually indicate those which are exported,
but should not be called directly. Update some of those declared in the
API and make it more readable.

page_pool_unmap_page() and page_pool_release_page() were doing
exactly the same thing calling __page_pool_clean_page().  Let's
rename __page_pool_clean_page() to page_pool_release_page() and
export it in order to show up on perf logs and get rid of
page_pool_unmap_page().

Finally rename __page_pool_put_page() to page_pool_put_page() since we
can now directly call it from drivers and rename the existing
page_pool_put_page() to page_pool_put_full_page() since they do the same
thing but the latter is trying to sync the full DMA area.

This patch also updates netsec, mvneta and stmmac drivers which use
those functions.

Acked-by: Toke Høiland-Jørgensen <redacted>
Signed-off-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
This doesn't apply cleanly, please respin.

Thank you.

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help