Re: [PATCH net-next v4] net: page_pool: API cleanup and comments
From: Jesper Dangaard Brouer <hidden>
Date: 2020-02-18 17:18:17
Also in:
bpf, lkml, netdev
On Tue, 18 Feb 2020 16:10:31 +0200 Ilias Apalodimas [off-list ref] wrote:
Functions starting with __ usually indicate those which are exported, but should not be called directly. Update some of those declared in the API and make it more readable. page_pool_unmap_page() and page_pool_release_page() were doing exactly the same thing calling __page_pool_clean_page(). Let's rename __page_pool_clean_page() to page_pool_release_page() and export it in order to show up on perf logs and get rid of page_pool_unmap_page(). Finally rename __page_pool_put_page() to page_pool_put_page() since we can now directly call it from drivers and rename the existing page_pool_put_page() to page_pool_put_full_page() since they do the same thing but the latter is trying to sync the full DMA area. This patch also updates netsec, mvneta and stmmac drivers which use those functions. Acked-by: Toke Høiland-Jørgensen <redacted> Signed-off-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
LGTM - on a quick review (not compile tested...). Acked-by: Jesper Dangaard Brouer <redacted>
--- Changes since v1: - Fixed netsec driver compilation error v2: - Improved comment description of page_pool_put_page() v3: - Properly define page_pool_release_page() in the header file within an ifdef since xdp.c uses it even if CONFIG_PAGE_POOL is not selected - rename __page_pool_clean_page -> page_pool_release_page and get rid of another redundant helper
-- Best regards, Jesper Dangaard Brouer MSc.CS, Principal Kernel Engineer at Red Hat LinkedIn: http://www.linkedin.com/in/brouer _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel