Thread (20 messages) 20 messages, 6 authors, 2020-11-09

Re: [PATCH 2/2] PCI: rockchip: Simplify optional regulator handling

From: Mark Brown <broonie@kernel.org>
Date: 2019-11-18 12:07:08
Also in: linux-pci, linux-rockchip

On Sat, Nov 16, 2019 at 12:54:20PM +0000, Robin Murphy wrote:
Null checks are both cheaper and more readable than having !IS_ERR()
splattered everywhere.
quoted hunk ↗ jump to hunk
-	if (IS_ERR(rockchip->vpcie3v3))
+	if (!rockchip->vpcie3v3)
 		return;
 
 	/*
@@ -611,6 +611,7 @@ static int rockchip_pcie_parse_host_dt(struct rockchip_pcie *rockchip)
 		if (PTR_ERR(rockchip->vpcie12v) != -ENODEV)
 			return PTR_ERR(rockchip->vpcie12v);
 		dev_info(dev, "no vpcie12v regulator found\n");
+		rockchip->vpcie12v = NULL;
According to the API NULL is a valid regulator.  We don't currently
actually do this but it's storing up surprises if you treat it as
invalid.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help