Thread (7 messages) 7 messages, 4 authors, 2016-03-19

[PATCH] [media] media: rename media unregister function

From: Mauro Carvalho Chehab <hidden>
Date: 2016-03-19 00:49:41
Also in: alsa-devel, linux-media, linux-samsung-soc

Em Fri, 18 Mar 2016 16:20:19 +0200
Sakari Ailus [off-list ref] escreveu:
Shuah Khan wrote:
quoted
On 03/18/2016 08:12 AM, Javier Martinez Canillas wrote:  
quoted
Hello Shuah,

On 03/18/2016 11:01 AM, Shuah Khan wrote:  
quoted
On 03/18/2016 07:05 AM, Mauro Carvalho Chehab wrote:  
quoted
Now that media_device_unregister() also does a cleanup, rename it
to media_device_unregister_cleanup().

Signed-off-by: Mauro Carvalho Chehab <redacted>  
I think adding cleanup is redundant. media_device_unregister()
would imply that there has to be some cleanup releasing resources.
I wouldn't make this change.
 
Problem is that there is a media_device_init() and media_device_register(),
so having both unregister and cleanup in this function will make very clear
that a single function is the counter part of the previous two operations.
   
Yes. I realized that this change is motivated by the fact that there is
the media_device_init() and we had the counterpart media_device_cleanup()
as an exported function. I still think there is no need to make the change
to add _cleanup() at the end of media_device_unregister(). It can be handled
in API documentation that it does both.  
I think that's a bad idea. People will only read the documentation when
something doesn't work. In this case it's easy to miss that.
After thinking about that, I guess the best is to use kref only
if the media_device_*devres functions are used. With this, we don't
need to touch at media_device_cleanup().

Just the patch to the ML:
	https://patchwork.linuxtv.org/patch/33533/

It was tested with HVR-950Q.

Regards,
Mauro
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help