[PATCH] [media] media: rename media unregister function
From: Javier Martinez Canillas <hidden>
Date: 2016-03-18 14:12:43
Also in:
alsa-devel, linux-media, linux-samsung-soc
From: Javier Martinez Canillas <hidden>
Date: 2016-03-18 14:12:43
Also in:
alsa-devel, linux-media, linux-samsung-soc
Hello Shuah, On 03/18/2016 11:01 AM, Shuah Khan wrote:
On 03/18/2016 07:05 AM, Mauro Carvalho Chehab wrote:quoted
Now that media_device_unregister() also does a cleanup, rename it to media_device_unregister_cleanup(). Signed-off-by: Mauro Carvalho Chehab <redacted>I think adding cleanup is redundant. media_device_unregister() would imply that there has to be some cleanup releasing resources. I wouldn't make this change.
Problem is that there is a media_device_init() and media_device_register(), so having both unregister and cleanup in this function will make very clear that a single function is the counter part of the previous two operations.
thanks, -- Shuah
Best regards, -- Javier Martinez Canillas Open Source Group Samsung Research America