On 02/12/2015 03:45 AM, Sebastian Andrzej Siewior wrote:
On 02/11/2015 09:42 PM, Peter Hurley wrote:
quoted
quoted
Reverting makes sense to me if it has caused a regression. Maybe Sebastian
can update his patch to do this based on some quirk flag instead?
That's fine with me. There's a 'bugs' field in struct 8250_uart_port and
UART_BUG_* defines in 8250/8250.h for that purpose.
Makes sense. Reading an empty FIFO does not look right. Maybe we should
do the bug flag the other way around? But I can do what I am told to so
if there is more fallout than just this Marvell UART I could come
around with a patch to the bug field for the older OMAP.
I agree with Russell on this; better to stick with the rx read that's been
running on 20 years of hardware.
That said, I don't think serial8250_do_startup() is really doing that much
for OMAP h/w startup; open-coding what omap_8250 really needs is probably
< 10 loc.
Regards,
Peter Hurley