Thread (4 messages) 4 messages, 4 authors, 2015-01-05

[PATCH] linux/kernel.h: merge ARRAY_AND_SIZE defines

From: Rusty Russell <hidden>
Date: 2015-01-05 04:28:14
Also in: linux-gpio, lkml

Alex Elder [off-list ref] writes:
On 12/23/2014 11:44 PM, Joe Perches wrote:
quoted
On Wed, 2014-12-24 at 14:38 +0900, Masahiro Yamada wrote:
quoted
ARRAY_AND_SIZE is a useful macro.  Its definition is already
duplicated in some headers.  Move it to include/linux/kernel.h.
I think it's not a good/useful macro and
would prefer the uses expanded instead.
For what it's worth, I agree.	-Alex
Me too.  It's fine in current usage, but I wouldn't want to see
more of it.

Cheers,
Rusty.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help