[PATCH] linux/kernel.h: merge ARRAY_AND_SIZE defines
From: Alex Elder <hidden>
Date: 2014-12-24 14:02:35
Also in:
linux-gpio, lkml
From: Alex Elder <hidden>
Date: 2014-12-24 14:02:35
Also in:
linux-gpio, lkml
On 12/23/2014 11:44 PM, Joe Perches wrote:
On Wed, 2014-12-24 at 14:38 +0900, Masahiro Yamada wrote:quoted
ARRAY_AND_SIZE is a useful macro. Its definition is already duplicated in some headers. Move it to include/linux/kernel.h.I think it's not a good/useful macro and would prefer the uses expanded instead.
For what it's worth, I agree. -Alex
The uses of ARRAY_AND_SIZE in structure definitions aren't particularly bad, but the ARRAY_AND_SIZE uses that hide the number of arguments in a function I think are suboptimal.