[PATCH 6/6] pci, acpi: Share ACPI PCI config space accessors.
From: Myron Stowe <hidden>
Date: 2014-11-21 04:00:23
Also in:
linux-acpi, linux-pci, lkml
On Thu, Nov 20, 2014 at 3:26 PM, Bjorn Helgaas [off-list ref] wrote:
On Wed, Nov 19, 2014 at 05:19:20PM +0100, Arnd Bergmann wrote:quoted
On Wednesday 19 November 2014 17:04:51 Tomasz Nowicki wrote:quoted
+/* + * raw_pci_read/write - ACPI PCI config space accessors. + * + * ACPI spec defines MMCFG as the way we can access PCI config space, + * so let MMCFG be default (__weak). + * + * If platform needs more fancy stuff, should provides its own implementation. + */ +int __weak raw_pci_read(unsigned int domain, unsigned int bus, + unsigned int devfn, int reg, int len, u32 *val) +{ + return pci_mmcfg_read(domain, bus, devfn, reg, len, val); +} + +int __weak raw_pci_write(unsigned int domain, unsigned int bus, + unsigned int devfn, int reg, int len, u32 val) +{ + return pci_mmcfg_write(domain, bus, devfn, reg, len, val); +} +I think it would be better to avoid __weak functions here, as they tend to be hard to follow when trying to understand the code.That's interesting. I would have said exactly the opposite -- I think the extra Kconfiggery is harder to follow than weak/strong functions :) But consistency is better than my personal opinion. Is there a consensus that we should use the Kconfig strategy instead of __weak?
I too find weak/strong functions easier to follow than "Kconfiggery" (nice term invention there).
quoted
How about using a Kconfig symbol like this: #ifdef CONFIG_ARCH_RAW_PCI_READWRITE int raw_pci_read(unsigned int domain, unsigned int bus, unsigned int devfn, int reg, int len, u32 *val); int raw_pci_write(unsigned int domain, unsigned int bus, unsigned int devfn, int reg, int len, u32 val); #else static inline int raw_pci_read(unsigned int domain, unsigned int bus, unsigned int devfn, int reg, int len, u32 *val) { return pci_mmcfg_read(domain, bus, devfn, reg, len, val); } static inline int raw_pci_write(unsigned int domain, unsigned int bus, unsigned int devfn, int reg, int len, u32 val) { return pci_mmcfg_write(domain, bus, devfn, reg, len, val); } #endif-- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo at vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html