[PATCH v3+1 5/5] ARM: DT: STi: STiH416: Add DT node for MiPHY365x
flat view
From: Sergei Shtylyov <hidden>
Date: 2014-07-20 17:56:30
Also in:
lkml
Hello. On 07/14/2014 11:58 AM, Lee Jones wrote:
quoted
quoted
The MiPHY365x is a Generic PHY which can serve various SATA or PCIe devices. It has 2 ports which it can use for either; both SATA, both PCIe or one of each in any configuration.
quoted
quoted
Acked-by: Mark Rutland <mark.rutland@arm.com> Acked-by: Alexandre Torgue <redacted> Signed-off-by: Lee Jones <redacted>
quoted
quoted
diff --git a/arch/arm/boot/dts/stih416-b2020.dts b/arch/arm/boot/dts/stih416-b2020.dts index 4e2df66..c3c2ac6 100644 --- a/arch/arm/boot/dts/stih416-b2020.dts +++ b/arch/arm/boot/dts/stih416-b2020.dts@@ -12,4 +12,16 @@ / { model = "STiH416 B2020"; compatible = "st,stih416-b2020", "st,stih416"; + + soc { + miphy365x_phy: miphy365x at fe382000 { + phy_port0: port at fe382000 {
quoted
I don't understand why are you creating the duplicate labels; doesn't 'dtc' complain about them?
I've never seen dtc complain about this:
DTC arch/arm/boot/dts/dra72-evm.dtb DTC arch/arm/boot/dts/stih407-b2120.dtb DTC arch/arm/boot/dts/stih415-b2000.dtb DTC arch/arm/boot/dts/stih415-b2020.dtb DTC arch/arm/boot/dts/stih416-b2000.dtb DTC arch/arm/boot/dts/stih416-b2020.dtb DTC arch/arm/boot/dts/stih416-b2020e.dtb DTC arch/arm/boot/dts/armada-375-db.dtb
Probably because they're not actually 'duplicate' per say. Rather they are the same node split into different files. I can remove the labels if required though.
Yeah, I don't see why you need them if you don't refer to them anywhere.
quoted
You could instead refer to them as:
quoted
&miphy365x_phy { };
I dislike this formatting. I find it convolutes the hierarchical structure and makes DTS (and some DTSI) files hard to read i.e hides parenthood etc.
Good point...
[...]
quoted
quoted
+ miphy365x_phy: miphy365x at fe382000 {
quoted
The ePAPR standard [1] says:
quoted
The name of a node should be somewhat generic, reflecting the function of the device and not its precise programming model.
Good point. Will change to 'phy'.
quoted
quoted
+ compatible = "st,miphy365x-phy"; + st,syscfg = <&syscfg_rear>; + #address-cells = <1>; + #size-cells = <1>; + ranges; + + phy_port0: port at fe382000 { + #phy-cells = <1>;
quoted
If these are PHY devices, they should be named "phy", not "port".
Then what do you call the parent node?
Oh, don't ask me, it wasn't my idea to have PHY subnodes. :-)
WBR, Sergei