[RFC PATCH 2/6] arm/arm64: KVM: Rename irq_active to irq_queued
From: Christoffer Dall <hidden>
Date: 2014-06-30 21:20:53
Also in:
kvm
On Sun, Jun 22, 2014 at 12:25:02PM +0100, Marc Zyngier wrote:
On 2014-06-14 21:51, Christoffer Dall wrote:quoted
We have a special bitmap on the distributor struct to keep track of when level-triggered interrupts are queued on the list registers. This was named irq_active, which is confusing, because the active state of an interrupt as per the GIC spec is a different thing, not specifically related to edge-triggered/level-triggered configurations but rather indicates an interrupt which has been ack'ed but not yet eoi'ed. Rename the bitmap and the corresponding accessor functions to irq_queued to clarify what this is actually used for.While I agree that irq_active is confusing, I would tend to object to irq_queued for similar reasons. Edge interrupts get queued as well.
yeah, but this is never checked for edge-triggered IRQs so I don't find that part confusing. I find the queued word suitable, because we set in in the _queue function and unset it in the unqueue function.
What this bit does is to allow or forbid resampling of a level interrupt. How about irq_resample instead? That would mandate a small refactor of the code (a bit set to one would allow resampling, which is the opposite of the current logic), but would look better, I believe. What do you think?
hmm, maybe. Feel like illustrating what you mean exactly in form of a patch? -Christoffer