Thread (15 messages) flat view 15 messages, 4 authors, 2014-07-07
STALE4422d REVIEWED: 1 (0M)

Revision rfc of 4 in this series; 1 review trailer.

Revisions (4)
  1. rfc [diff vs current]
  2. rfc [diff vs current]
  3. rfc current
  4. v1 [diff vs current]

[RFC PATCH 1/6] arm/arm64: KVM: Rename irq_state to irq_pending

From: Marc Zyngier <hidden>
Date: 2014-06-22 11:20:04
Also in: kvm

On 2014-06-14 21:51, Christoffer Dall wrote:
The irq_state field on the distributor struct is ambiguous in its
meaning; the comment says it's the level of the input put, but that
doesn't make much sense for edge-triggered interrupts.  The code
actually uses this state variable to check if the interrupt is in the
pending state on the distributor so clarify the comment and rename 
the
actual variable and accessor methods.

Signed-off-by: Christoffer Dall <redacted>
Looks good to me.

Acked-by: Marc Zyngier <redacted>

         M.
-- 
Who you jivin' with that Cosmik Debris?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help