[PATCH 10/34] ARM: imx: include iram.h rather than mach/iram.h
From: Shawn Guo <hidden>
Date: 2012-09-17 05:34:39
Subsystem:
arm port, the rest · Maintainers:
Russell King, Linus Torvalds
From: Shawn Guo <hidden>
Date: 2012-09-17 05:34:39
Subsystem:
arm port, the rest · Maintainers:
Russell King, Linus Torvalds
Rename mach-imx/include/mach/iram.h to mach-imx/iram.h, and update users
to include iram.h rather than mach/iram.h.
Signed-off-by: Shawn Guo <redacted>
---
arch/arm/mach-imx/{include/mach => }/iram.h | 0
arch/arm/mach-imx/iram_alloc.c | 3 ++-
2 files changed, 2 insertions(+), 1 deletion(-)
rename arch/arm/mach-imx/{include/mach => }/iram.h (100%)
diff --git a/arch/arm/mach-imx/include/mach/iram.h b/arch/arm/mach-imx/iram.h
similarity index 100%
rename from arch/arm/mach-imx/include/mach/iram.h
rename to arch/arm/mach-imx/iram.h
diff --git a/arch/arm/mach-imx/iram_alloc.c b/arch/arm/mach-imx/iram_alloc.c
index 074c386..6c80424 100644
--- a/arch/arm/mach-imx/iram_alloc.c
+++ b/arch/arm/mach-imx/iram_alloc.c@@ -22,7 +22,8 @@ #include <linux/module.h> #include <linux/spinlock.h> #include <linux/genalloc.h> -#include <mach/iram.h> + +#include "iram.h" static unsigned long iram_phys_base; static void __iomem *iram_virt_base;
--
1.7.9.5