Thread (63 messages) flat view 63 messages, 9 authors, 2012-05-14
STALE5248d

[PATCH 08/13] ARM: OMAP5: Add the WakeupGen IP updates.

From: Roger Quadros <hidden>
Date: 2012-05-10 11:48:21
Also in: linux-omap

On 05/10/2012 02:42 PM, Shilimkar, Santosh wrote:
On Thu, May 10, 2012 at 5:06 PM, Roger Quadros [off-list ref] wrote:
quoted
Hi,

On 05/03/2012 10:26 AM, R Sricharan wrote:
quoted
From: Santosh Shilimkar <redacted>

OMAP4 and OMAP5 share same WakeupGen IP with below few udpates on OMAP5.
- Additional 32 interrupt support is added w.r.t OMAP4 design.
- The AUX CORE boot registers are now made accessible from non-secure SW.
- SAR offset are changed and PTMSYNC* registers are removed from SAR.

Patch updates the WakeupGen code accordingly.

Signed-off-by: Santosh Shilimkar <redacted>
Signed-off-by: R Sricharan <redacted>
---
 arch/arm/mach-omap2/include/mach/omap-wakeupgen.h |    6 +
 arch/arm/mach-omap2/omap-hotplug.c                |   24 ++++-
 arch/arm/mach-omap2/omap-smp.c                    |   19 +++-
 arch/arm/mach-omap2/omap-wakeupgen.c              |  110 +++++++++++++++-----
 arch/arm/mach-omap2/omap4-sar-layout.h            |   12 ++-
 5 files changed, 135 insertions(+), 36 deletions(-)
diff --git a/arch/arm/mach-omap2/include/mach/omap-wakeupgen.h b/arch/arm/mach-omap2/include/mach/omap-wakeupgen.h
index 548de90..4d700bc 100644
--- a/arch/arm/mach-omap2/include/mach/omap-wakeupgen.h
+++ b/arch/arm/mach-omap2/include/mach/omap-wakeupgen.h
@@ -11,15 +11,20 @@
 #ifndef OMAP_ARCH_WAKEUPGEN_H
 #define OMAP_ARCH_WAKEUPGEN_H

+/* OMAP4 and OMAP5 has same base address */
+#define OMAP_WKUPGEN_BASE                    0x48281000
unnecessary change, why don't you just use OMAP44XX_WKUPGEN_BASE or
define this in the same header as OMAP44XX_WKUPGEN_BASE?
Just to avoid confusion about OMAP44XX and OMAP54XX. It's cleaner to
remove the OMAP44XX reference if the base is generic and not depend
on OMAP4/5.

It's not un-necessary change as such.
OK, is OMAP_WKUPGEN_BASE applicable for OMAPs prior to OMAP4? If not the
naming scheme does not look appropriate.

regards,
-roger
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help