Thread (9 messages) 9 messages, 3 authors, 2024-03-05

Re: [PATCH 2/2] clock_nanosleep.2, nanosleep.2: Use 'duration' rather than 'request'

flat view

From: Alejandro Colomar <alx@kernel.org>
Date: 2024-03-05 01:11:43
Also in: linux-man

On Mon, Mar 04, 2024 at 04:56:13PM -0800, enh wrote:
quoted
quoted
int clock_nanosleep(clockid_t __clock, int __flags, const struct
timespec* _Nonnull __time, struct timespec* _Nullable __remainder);
Hmmmm, that's the best name, meaningfully, I think.  But I've been
trying to avoid it.  I don't like using names of standard functions in
identifiers; it might confuse.  As an alternative, I thought of 't'.
What do you think?
as you can see, i've taken the "the leading `__` means we get to
trample whatever we like" approach :-)

(we build bionic with hidden visibility and an explicit list of
symbols for the linker to export, so we'd have to be trying quite hard
to trip over ourselves.)
Yeah, I was worried about the manual page  :)


-- 
<https://www.alejandro-colomar.es/>
Looking for a remote C programming job at the moment.

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help