Re: [PATCH 2/2] clock_nanosleep.2, nanosleep.2: Use 'duration' rather than 'request'
flat view
From: enh <hidden>
Date: 2024-03-05 00:56:25
Also in:
linux-man
On Mon, Mar 4, 2024 at 4:34 PM Alejandro Colomar [off-list ref] wrote:
Hi Elliott, On Mon, Mar 04, 2024 at 04:18:28PM -0800, enh wrote:quoted
thanks! https://android-review.googlesource.com/c/platform/bionic/+/2987070 changes to /** * [clock_nanosleep(2)](http://man7.org/linux/man-pages/man2/clock_nanosleep.2.html) * sleeps for the given time (or until the given time if the TIMER_ABSTIME flag * is used), as measured by the given clock. * * Returns 0 on success, and returns -1 and returns an error number on failure. * If the sleep was interrupted by a signal, the return value will be `EINTR` * and `remainder` will be the amount of time remaining. */ int clock_nanosleep(clockid_t __clock, int __flags, const struct timespec* _Nonnull __time, struct timespec* _Nullable __remainder);Hmmmm, that's the best name, meaningfully, I think. But I've been trying to avoid it. I don't like using names of standard functions in identifiers; it might confuse. As an alternative, I thought of 't'. What do you think?
as you can see, i've taken the "the leading `__` means we get to trample whatever we like" approach :-) (we build bionic with hidden visibility and an explicit list of symbols for the linker to export, so we'd have to be trying quite hard to trip over ourselves.)
Have a lovely night! Alex -- <https://www.alejandro-colomar.es/> Looking for a remote C programming job at the moment.