On Thu, May 20, 2021 at 04:59:23PM +0300, Amir Goldstein wrote:
On Thu, May 20, 2021 at 5:11 AM Matthew Bobrowski [off-list ref] wrote:
quoted
The copy_info_to_user() function has been repurposed with the idea to
Sorry I gave comment on patch 5 before I knew you repurposed
copy_info_to_user().
Perhaps it would be better to give a non ambiguous name like
copy_info_records_to_user() or
^ I like this.
copy_fid_info_records_to_user() and leave pidfd out of this helper.
If you do wish to keep pidfd copy inside this helper and follow my
suggestion on patch 5 you will have to pass in pidfd as another argument.
I'd like to keep all the info record related copying branching out
from a single helper, which in this case will now be
copy_info_records_to_user().
/M