Re: [PATCH 4/5] fanotify/fanotify_user.c: introduce a generic info record copying function
From: Amir Goldstein <amir73il@gmail.com>
Date: 2021-05-20 14:00:02
Also in:
linux-fsdevel
From: Amir Goldstein <amir73il@gmail.com>
Date: 2021-05-20 14:00:02
Also in:
linux-fsdevel
On Thu, May 20, 2021 at 5:11 AM Matthew Bobrowski [off-list ref] wrote:
The copy_info_to_user() function has been repurposed with the idea to
Sorry I gave comment on patch 5 before I knew you repurposed copy_info_to_user(). Perhaps it would be better to give a non ambiguous name like copy_info_records_to_user() or copy_fid_info_records_to_user() and leave pidfd out of this helper. If you do wish to keep pidfd copy inside this helper and follow my suggestion on patch 5 you will have to pass in pidfd as another argument. Thanks, Amir.