Thread (60 messages) 60 messages, 6 authors, 2020-12-10

Re: [PATCH v15 06/26] x86/mm: Change _PAGE_DIRTY to _PAGE_DIRTY_HW

From: Yu, Yu-cheng <hidden>
Date: 2020-12-03 15:57:40
Also in: linux-arch, linux-doc, linux-mm, lkml

On 12/3/2020 7:12 AM, Dave Hansen wrote:
On 12/3/20 1:19 AM, Borislav Petkov wrote:
quoted
On Tue, Nov 10, 2020 at 08:21:51AM -0800, Yu-cheng Yu wrote:
quoted
Before introducing _PAGE_COW for non-hardware memory management purposes in
the next patch, rename _PAGE_DIRTY to _PAGE_DIRTY_HW and _PAGE_BIT_DIRTY to
_PAGE_BIT_DIRTY_HW to make meanings more clear.  There are no functional
changes from this patch.
There's no guarantee for "next" or "this" patch when a patch gets
applied so reword your commit message pls.

Also, I fail to understand here what _PAGE_DIRTY_HW makes more clear?
The page dirty bit is clear enough to me so why the churn?
Once upon a time in this set, we had:

	_PAGE_DIRTY	(the old hardware bit)
and
	_PAGE_DIRTY_SW	(the new shadow stack necessitated bit)

In *that* case, it made sense to change the name of the hardware one to
help differentiate them.  But, over time, we changed _PAGE_DIRTY_SW to
_PAGE_COW.

I think you're right.  The renaming is just churn now with the current
naming.
Ok, I will drop this patch.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help