On Thu, Sep 10, 2020 at 09:59:05AM +0800, Tom Yan wrote:
If we rename it to e.g. SG_GET_MAX_XFER_BYTES, it will still break
applications unless we also keep the wrong/ugly/confusing name (and
you lose the advantage/generality that the two ioctls can be used on
both sg and "pure" block devices; which seems to be the case of some
SG_* ioctls as well).
How is that an advantage? Applications that works with block devices
don't really work with a magic passthrough character device.
I don't really care enough though. I mean, I'm okay with
SG_GET_MAX_XFER_BYTES *and* NO "improper" BLKSECTGET. If that will get
the patch series in, I am willing to send a new version. If not, I'm
just gonna drop this.
You must assume that there are applications already that depend in the
"weird" BLKSECTGET on sg, given that it has been around so long. Any
change to the semantics will break them.