Thread (107 messages) flat view 107 messages, 7 authors, 2020-04-08

Re: [RFC PATCH v9 11/27] drm/i915/gvt: Change _PAGE_DIRTY to _PAGE_DIRTY_BITS

From: Yu-cheng Yu <hidden>
Date: 2020-04-03 15:42:09
Also in: linux-arch, linux-doc, linux-mm, lkml

On Wed, 2020-02-26 at 14:04 -0800, Dave Hansen wrote:
On 2/5/20 10:19 AM, Yu-cheng Yu wrote:
quoted
diff --git a/drivers/gpu/drm/i915/gvt/gtt.c b/drivers/gpu/drm/i915/gvt/gtt.c
index 4b04af569c05..e467ca182633 100644
--- a/drivers/gpu/drm/i915/gvt/gtt.c
+++ b/drivers/gpu/drm/i915/gvt/gtt.c
@@ -1201,7 +1201,7 @@ static int split_2MB_gtt_entry(struct intel_vgpu *vgpu,
 	}
 
 	/* Clear dirty field. */
-	se->val64 &= ~_PAGE_DIRTY;
+	se->val64 &= ~_PAGE_DIRTY_BITS;
 
 	ops->clear_pse(se);
 	ops->clear_ips(se);
Are the i915 maintainers on cc?

Shouldn't this use pte_mkclean() instead of open-coding?
These functions look like a set of pte_* equivalent for the driver.  They all
use the bits directly.  Add its maintainers to cc.

Yu-cheng
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help