On Fri, Jan 10, 2020 at 4:02 AM Thomas Gleixner [off-list ref] wrote:
Vincenzo Frascino [off-list ref] writes:
quoted
On 1/10/20 11:42 AM, Thomas Gleixner wrote:
quoted
quoted
quoted
+» » /*·goto·allows·to·avoid·extra·inlining·of·do_hres.·*/
+» » goto·out_hres;
What is the performance impact of "goto out_hres"?
On x86 it's invisible at least in my limited testing.
On arm64 as well based on mine as well. Shall we keep the code more readable
here (without goto)?
The delta patch below makes it readable again and also avoids the double
inlining. Quick testing shows no difference.
My tests show no difference too and the code looks more readable. Thanks!
Thanks,
tglx