Thread (55 messages) flat view 55 messages, 9 authors, 2020-02-18

Re: [PATCHv8 02/34] lib/vdso: make do_hres and do_coarse as __always_inline

From: Vincenzo Frascino <hidden>
Date: 2020-01-10 11:44:54
Also in: lkml


On 1/10/20 11:42 AM, Thomas Gleixner wrote:
Vincenzo Frascino [off-list ref] writes:
quoted
On 11/12/19 1:26 AM, Dmitry Safonov wrote:
quoted
+» » vd·=·&vd[CS_HRES_COARSE];
+out_hres:
+» » return·do_hres(vd,·clock,·ts);
» }·else·if·(msk·&·VDSO_COARSE)·{
» » do_coarse(&vd[CS_HRES_COARSE],·clock,·ts);
» » return·0;
» }·else·if·(msk·&·VDSO_RAW)·{
-» » return·do_hres(&vd[CS_RAW],·clock,·ts);
+» » vd·=·&vd[CS_RAW];
+» » /*·goto·allows·to·avoid·extra·inlining·of·do_hres.·*/
+» » goto·out_hres;
What is the performance impact of "goto out_hres"?
On x86 it's invisible at least in my limited testing.
On arm64 as well based on mine as well. Shall we keep the code more readable
here (without goto)?
Thanks,

        tglx
-- 
Regards,
Vincenzo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help