Hi Chris,
Thanks for looking at this patch.
On Thu, Jan 09, 2020 at 02:53:55PM +0000, Chris Down wrote:
Chen Yu writes:
quoted
+#ifdef CONFIG_PROC_CPU_RESCTRL
+ ONE("resctrl", S_IRUGO, proc_resctrl_show),
There was already some discussion about "resctrl" by itself being a
misleading name, hence why the CONFIG option eventually became
CONFIG_X86_CPU_RESCTRL. Can you please rethink the name of this /proc file,
and have it at least be "cpu_resctrl" or "x86_resctrl" or similar? :-)
Ok, I'll change the name from "resctrl" to "cpu_resctrl", because:
1. it is a CPU feature so a 'cpu' prefixed seems to be more obvious,
2. other CPUs than x86 could also use this file in the future.
Thanks,
Chenyu