Thread (42 messages) 42 messages, 7 authors, 2019-10-30

Re: [RFC PATCH v2 3/5] btrfs: generalize btrfs_lookup_bio_sums_dio()

flat view

From: Nikolay Borisov <hidden>
Date: 2019-10-16 09:22:39
Also in: linux-btrfs, linux-fsdevel


On 15.10.19 г. 21:42 ч., Omar Sandoval wrote:
From: Omar Sandoval <redacted>

This isn't actually dio-specific; it just looks up the csums starting at
the given offset instead of using the page index. Rename it to
btrfs_lookup_bio_sums_at_offset() and add the dst parameter. We might
even want to expose __btrfs_lookup_bio_sums() as the public API instead
of having two trivial wrappers, but I'll leave that for another day.
IMO exposing btrfs_lookup_bio_sums and adding proper kernel doc for its
parameters is the correct way forward. Consider doing this if the
general direction of this patchset is accepted and before sending the
final revision.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help