On Wed, Jun 19, 2019 at 12:34 AM David Howells [off-list ref] wrote:
quoted
Same goes for vfs_parse_sb_flag() btw. It should be moved into each
filesystem's ->parse_param() and not be a mandatory thing.
I disagree. Every filesystem *must* be able to accept these standard flags,
even if it then ignores them.
"posixacl" is not a standard flag. It never was accepted by mount(8)
so I don't see where you got that from.
Can you explain why you think "mand", "sync", "dirsync", "lazytime"
should be accepted by a filesystem such as proc? The argument that it
breaks userspace is BS, because this is a new interface, hence by
definition we cannot break old userspace. If mount(8) wants to use
the new API and there really is breakage if these options are rejected
(which I doubt) then it can easily work around that by ignoring them
itself.
Also why should "rw" not be rejected for filesystems which are
read-only by definition, such as iso9660?
Thanks,
Miklos