On Mon, May 11, 2015 at 08:57:59AM -0400, Steven Rostedt wrote:
NO_HZ_LEAVE_ME_THE_FSCK_ALONE!
NO_HZ_OVERFLOWING?
Kconfig naming controversy aside, I believe this patchset is addressing
a real need. Might need additional adjustment, but something useful.
Thanx, Paul
On Sat, 9 May 2015 09:05:38 +0200
Ingo Molnar [off-list ref] wrote:
quoted
So I think we should either rename NO_HZ_FULL to NO_HZ_PURE, or keep
it at NO_HZ_FULL: because the intention of NO_HZ_FULL was always to be
such a 'zero overhead' mode of operation, where if user-space runs, it
won't get interrupted in any way.
All kidding aside, I think this is the real answer. We don't need a new
NO_HZ, we need to make NO_HZ_FULL work. Right now it doesn't do exactly
what it was created to do. That should be fixed.
Please lets get NO_HZ_FULL up to par. That should be the main focus.
-- Steve