Thread (153 messages) flat view 153 messages, 15 authors, 2015-06-24

Re: [PATCH v2 1/7] eeprom: Add a simple EEPROM framework for eeprom providers

From: Mark Brown <broonie@kernel.org>
Date: 2015-03-24 20:55:46
Also in: linux-arm-kernel, linux-arm-msm, linux-devicetree, lkml

On Tue, Mar 24, 2015 at 07:26:45PM +0000, Srinivas Kandagatla wrote:
On 24/03/15 19:02, Mark Brown wrote:
quoted
On Tue, Mar 24, 2015 at 06:34:32PM +0000, Srinivas Kandagatla wrote:
quoted
quoted
On 24/03/15 17:23, Mark Brown wrote:
quoted
quoted
quoted
quoted
quoted
quoted
quoted
regmap_get_size(regmap)
quoted
quoted
quoted
quoted
quoted
This is already there.
quoted
quoted
quoted
Sorry, I can't see any such api atleast in v4.0-rc5 and linux-next? Are you
referring to another api which does the same job?
quoted
regmap_get_val_bytes()
This would return value bytes, but I wanted is the regmap->max_register
value which would be used for sanity checks in eeprom-core.
Then you *really* want to pick a better name then, I'd never have
inferred that meaning from "size" (consider sparse register maps for
example).  Like I said, send patches (preferrably showing the users as
well).

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help