Am Montag, 22. Dezember 2014, 22:27:30 schrieb Herbert Xu:
Hi Herbert,
On Sun, Dec 07, 2014 at 11:23:48PM +0100, Stephan Mueller wrote:
quoted
Allow user space to seed / reset the RNG via a setsockopt.
This patch reuses alg_setkey to copy data into the kernel. The
alg_setkey is now used for two mechanisms: setkey and seeding.
The function is extended by the providing the function pointer
to the function handling the copied data.
As the alg_setkey is now usable for more than just setkey, it is renamed
to alg_setop.
Just call it setkey, there is no harm in treating the seed as a key
is there?
In fact we should have done this from the very start.
crypto_rng_reset should be renamed crypto_rng_setkey.
Ok, that means I will drop this patch entirely and wire up the reseeding
function in algif_rng.c with setkey.
Cheers,
--
Ciao
Stephan