Am Donnerstag, 20. November 2014, 21:40:29 schrieb Herbert Xu:
Hi Herbert,
On Thu, Nov 20, 2014 at 02:10:00PM +0100, Stephan Mueller wrote:
quoted
What about the following
if (p->cru_driver_name[0]
If the driver name is not empty
quoted
alg = crypto_alg_match(p, 1);
Do an exact match using the driver name
quoted
else
alg = crypto_alg_match(p, 0);
Otherise use the generic name for a fuzzy match.
If cru_driver_name is not empty then exact will never be used, no?
If the code suggestion does not follow my words outlined above, I want my
words to be considered ;-)
Yet, I am unsure where the code deviates from my words.
Cheers,
--
Ciao
Stephan