Re: [PATCH v8 27/46] KVM: selftests: Rename guest_memfd{,_offset} to gmem_{fd,offset}
From: sashiko-bot@kernel.org
Date: 2026-06-19 00:56:09
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The renaming of 'guest_memfd' to the 'gmem_' prefix for local variables and parameters is incomplete across the selftests subsystem.
--
commit ce3052fec38d2438ddf1c5609c3518407024b32a
Author: Sean Christopherson [off-list ref]
KVM: selftests: Rename guest_memfd{,_offset} to gmem_{fd,offset}
This commit renames local variables and function parameters for the guest
memory file descriptor and its offset to use a "gmem_" prefix. No
functional changes are intended.
Rename local variables and function parameters for the guest memory file descriptor and its offset to use a "gmem_" prefix instead of "guest_memfd_".
[Severity: Low]
This isn't a bug, but is this renaming incomplete?
The commit message implies a general rename across the selftests, but the
patch only updates the core library files (kvm_util.c and kvm_util.h). Other
test files still use the old naming conventions.
For example, in tools/testing/selftests/kvm/set_memory_region_test.c:
test_invalid_memory_region_flags() {
...
int guest_memfd = vm_create_guest_memfd(vm, MEM_REGION_SIZE, 0);
...
}
And in tools/testing/selftests/kvm/guest_memfd_test.c:
static void test_create_guest_memfd_invalid_sizes(struct kvm_vm *vm,
u64 guest_memfd_flags)
Should these remaining instances also be updated to the gmem_ prefix to
keep the internal naming scheme consistent?
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260618-gmem-inplace-conversion-v8-0-9d2959357853@google.com?part=27