Thread (19 messages) 19 messages, 4 authors, 2021-07-15

Re: [PATCH 0/7] namei: clean up retry logic in various do_* functions

From: Dmitry Kadashev <hidden>
Date: 2021-07-12 12:41:28
Also in: linux-fsdevel

On Mon, Jul 12, 2021 at 7:37 PM Dmitry Kadashev [off-list ref] wrote:
Suggested by Linus in https://lore.kernel.org/io-uring/CAHk-=wh=cpt_tQCirzFZRPawRpbuFTZ2MxNpXiyUF+eBXF=+sw@mail.gmail.com/ (local)

This patchset does all the do_* functions one by one. The idea is to
move the main logic to a helper function and handle stale retries /
struct filename cleanups outside, which makes the logic easier to
follow.

There is one minor change in the behavior: filename_lookup() /
filename_parentat() / filename_create() do their own retries on ESTALE
(regardless of flags), and previously they were exempt from retries in
the do_* functions (but they *were* called on retry - it's just the
return code wasn't checked for ESTALE). And now the retry is done on
the upper level, and so technically it could be called a behavior
change. Hopefully it's an edge case where an additional check does not
matter.

On top of https://lore.kernel.org/io-uring/20210708063447.3556403-1-dkadashev@gmail.com/ (local)
Since this is on top of the stuff that is going to be in the Jens' tree
only until the 5.15 merge window, I'm assuming this series should go
there as well.

-- 
Dmitry Kadashev
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help