Re: [PATCH 01/13] setup: rename `check_repository_format_gently()`
From: Justin Tobler <hidden>
Date: 2026-07-06 21:27:24
From: Justin Tobler <hidden>
Date: 2026-07-06 21:27:24
On 26/06/30 01:47PM, Patrick Steinhardt wrote:
The function `check_repository_format_gently()` receives a format as
input. An unknowing reader may thus suspect that this function actually
checks the passed-in format for consistency. While the function indeed
checks the repository format, it actually serves two purposes:
- It reads the repository's format and populates the passed-in format
with that information.
- It then indeed checks whether the format is consistent.Ok
Rename the function to `read_and_verify_repository_format()` to clarify its functionality. While at it, reorder the parameters so that the format comes first to better match other functions that pass around the format.
I agree that the current name is a bit misleading so this change sounds reasonable to me. The patch itself is just a trivial rename and reorder of parameters. Looks good. -Justin